Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2026 - 02:00 EDT
Scheduled
To ensure optimal performance and the best Brightspace experience, D2L will perform a failover of the Production infrastructure on Wednesday, March 25, 2026, at 2:00 a.m. The expected downtime is less than 15 minutes. During this failover, no notifications will be sent, and maintenance pages will not be displayed. D2L selected this time based on low-traffic analysis. We apologize for any inconvenience.
This maintenance is expected to affect GeorgiaVIEW access or service. In the event that you experience any issues with GeorgiaVIEW services after this maintenance, please contact the USG Service Desk at 877-251-2644 or support@usg.edu.
USG institution affected by this maintenance are: Augusta University
Posted Mar 24, 2026 - 14:05 EDT
This scheduled maintenance affected: GeorgiaVIEW Online Learning (Augusta University).