SYSTEMS STATUS
OneUSG Connect Benefits Issues Reported
Incident Report for USG Services
Resolved
OneUSG Connect - Benefits Portal is now available after an unexpected outage and should be operating normally. Phone calls can now be placed to OneUSG Connect - Benefits Customer Care locations.

In the event that you experience any further issues, please contact OneUSG Connect Support by email at oneusgsupport@usg.edu
Posted 3 months ago. Mar 04, 2019 - 16:34 EST
Investigating
OneUSG Connect - Benefits is experiencing connectivity issues.

This is directly impacting telephone call routing to representatives at OneUSG Connect - Benefits Customer Care locations as well as availability to the OneUSG Connect - Benefits Portal.

We are committed to resolving this issue as quickly as possible and we apologize for any inconvenience this may cause. We will provide an update as soon as more information is available.

If you have questions or concerns, please contact OneUSG Connect Support by email at oneusgsupport@usg.edu or toll free at 877-251-2644.
Posted 3 months ago. Mar 04, 2019 - 12:56 EST
This incident affected: OneUSG Connect (OneUSG Connect - Benefits).