SYSTEMS STATUS
SSO Access Issues Reported - USO Employees
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that Single Sign-On for employees of the University System of Georgia is functioning normally at this time.

In the event that you experience any further issues with Single Sign-On, please contact the ITS Helpdesk at: helpdesk@usg.edu or 706-583-2001.
Posted Jan 14, 2021 - 07:42 EST
Investigating
Information Technology Services (ITS) is currently investigating issues with Single Sign-On for employees of the University System of Georgia. Affected users will not be able to use Single Sign-On. Technicians are currently working to resolve this issue. More information will be posted here as it becomes available.
Posted Jan 14, 2021 - 06:37 EST
This incident affected: PeachNet Network (USO Athens Office, USO Atlanta Office, USO Shared Services Center).