SYSTEMS STATUS
OneUSG Connect Issues Reported
Incident Report for USG Services
Resolved
After monitoring the situation, we have confirmed the stability of OneUSG Connect. The system should continue operating normally.

In the event that you experience any further issues, please contact OneUSG Connect Support by email at oneusgsupport@usg.edu.
Posted Mar 29, 2021 - 16:39 EDT
Investigating
OneUSG Connect Support has received reports of users experiencing issues with OneUSG Connect Employee Self Service. When clicking on the Pay tile, it continues to spin. Callers have tried changing browsers and deleting cache and cookies, with no success.

We are actively monitoring and will provide updates as they are made available.

We are committed to resolving this issue as quickly as possible and we apologize for any inconvenience this may cause. We will provide an update as soon as more information is available.

If you have questions or concerns, please contact OneUSG Connect Support by email at: oneusgsupport@usg.edu
Posted Mar 26, 2021 - 11:22 EDT
This incident affected: OneUSG Connect (OneUSG Connect – Employee and Manager Self-Service).