SYSTEMS STATUS
D2L Brightspace Issues Reported - Georgia Southern University
Incident Report for USG Services
Resolved
This incident has been resolved.
Posted May 14, 2024 - 08:54 EDT
Investigating
Between 7:15 a.m. and 7:30 a.m. on Tuesday, May 14, 2024, Georgia Southern University users may have experienced intermittent slowness with Brightspace by D2L. Service has now been restored. If you experience any further issues with Brightspace, please contact the ITS Help Desk at helpdesk@usg.edu or 706-583-2001.
Posted May 14, 2024 - 08:25 EDT
This incident affected: GeorgiaVIEW Online Learning (Georgia Southern University).