SYSTEMS STATUS

Fiber Maintenance - Abraham Baldwin Agricultural College

Incident Report for USG Services

Resolved

Abraham Baldwin Agricultural College (ABAC) campus is back up and online as of 2:34 a.m.

In the event that you experience any further issues with network access, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Mar 20, 2026 - 08:22 EDT

Identified

Abraham Baldwin Agricultural College (ABAC) is currently down due to being isolated with multiple fiber maintenances.

Updates will be posted here as they become available.
Posted Mar 20, 2026 - 01:09 EDT
This incident affected: PeachNet Network (Abraham Baldwin Agricultural College) and GeorgiaVIEW Online Learning (Abraham Baldwin Agricultural College (XPROD)).