SYSTEMS STATUS

OneUSG Connect Issues Reported

Incident Report for USG Services

Resolved

After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of OneUSG Connect. The system should continue operating normally.

In the event that you experience any further issues with OneUSG Connect, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Apr 01, 2025 - 13:33 EDT

Monitoring

OneUSG Connect Support previously received reports of users experiencing connection issues to OneUSG Connect. These issues have been resolved, and we are actively monitoring for any further issues.

If you have questions or concerns, please contact the USG Service Desk by email at: support@usg.edu
Posted Mar 31, 2025 - 09:46 EDT
This incident affected: OneUSG Connect (OneUSG Connect – Database, OneUSG Connect – Core Practitioner, OneUSG Connect – Employee and Manager Self-Service, OneUSG Connect- Careers Applicant Access).