SYSTEMS STATUS

PeachNet Network Outage - University of North Georgia - Blue Ridge Campus (NGABLU)

Incident Report for USG Services

Resolved

After monitoring the situation, Network Support Services (NSS) has confirmed the stability of network access at University of North Georgia - Blue Ridge Campus (NGABLU). The system should continue operating normally.

In the event that you experience any further issues with access to the network, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Nov 13, 2025 - 08:51 EST

Monitoring

Network Support Services (NSS) is reporting that full functionality of network access at University of North Georgia - Blue Ridge Campus (NGABLU) has been restored. We will continue to monitor this system. If you are still experiencing issues with network access, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Nov 12, 2025 - 12:09 EST

Investigating

Network Support Services (NSS) is currently investigating reports of issues with network access at University of North Georgia - Blue Ridge Campus (NGABLU). As of 11:00 a.m. affected users may be experiencing problems with access to the network. Technicians are currently investigating the outage.

Additional information will be posted here as it becomes available.
Posted Nov 12, 2025 - 11:47 EST
This incident affected: PeachNet Network (University of North Georgia).