SYSTEMS STATUS
USO Conference Room Closure - Trinity Washington - Boardroom 7007 Technology
Incident Report for USG Services
Resolved
Trinity Washington Room 7th floor Boardroom (7007) Technology repairs have been completed and the conference room is now open.
Posted Jun 02, 2023 - 15:49 EDT
Identified
Trinity Washington Room 7th floor Boardroom (7007) Technology is not working and is scheduled for repair.
Posted May 31, 2023 - 11:29 EDT
This incident affected: Internal USO Services (USO Conference Rooms/Classrooms).