SYSTEMS STATUS

Enterprise Data Management & Analytics: Business Intelligence and Analytics

Incident Report for USG Services

Resolved

Information Technology Services (ITS) has confirmed that Enterprise Data Management and Analytics' Business Intelligence and Analytics is functioning normally at this time.

In the event that you experience any further issues with degraded service, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted May 26, 2026 - 16:05 EDT

Monitoring

Microsoft has reported partial recovery and is continuing to apply mitigations across platforms. Users may experience slowness or errors when loading dashboards or other Fabric objects.

Microsoft updates can be found at https://support.fabric.microsoft.com/support/

This service impacts Enterprise Data Management and Analytics' Business Intelligence and Analytics
Posted May 18, 2026 - 15:53 EDT

Update

Microsoft PowerBI and Fabric are currently experiencing an outage. Users may not be able to access dashboards or other Fabric objects.

Microsoft updates can be found at https://support.fabric.microsoft.com/support/

This service impacts Enterprise Data Management and Analytics' Business Intelligence and Analytics
Posted May 18, 2026 - 14:37 EDT

Identified

Earlier this morning, Microsoft notified customers of degraded service across their platform. Users may experience slowness or errors when loading dashboards or other Fabric objects.

Microsoft updates can be found at https://support.fabric.microsoft.com/support/

This service impacts Enterprise Data Management and Analytics' Business Intelligence and Analytics
Posted May 18, 2026 - 13:47 EDT
This incident affected: Enterprise Data Management and Analytics (Business Intelligence & Analytics).