SYSTEMS STATUS
GIL Courier Service Schedule Interruption
Incident Report for USG Services
Resolved
This incident has been resolved. Pick up and deliveries are back to normal.
Posted 4 months ago. Feb 05, 2018 - 08:30 EST
Identified
Due to vehicle issues, GIL Express Courier Service will not make deliveries or pickups to the following USG libraries today:

- Athens - Clarke County Library
- Elbert County Library
- Gainsville State College
- Georgia Gwinnett College
- Gwinnett Co Public Library
- Hart County Library
- Piedmont Regional Library
- University of Georgia (Athens, Lawrenceville and Science)

Normal GIL Express Courier Services are expected to resume Monday, February 5, 2018 .
Posted 4 months ago. Feb 02, 2018 - 16:28 EST
This incident affected: GALILEO - Georgia's Virtual Library (GIL Express).