SYSTEMS STATUS
GeorgiaView Access Issues Reported - University of Georgia
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that Brightspace D2L myID is functioning normally at this time.

In the event that you experience any further issues with Brightspace D2L myID, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted May 19, 2018 - 10:25 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of an issue with Brightspace D2L myID at the University of Georgia. Affected users may be experiencing inability to login via the myID function as well as error messages when attempting to log in. Additional information will be posted here when it becomes available.
Posted May 19, 2018 - 09:19 EDT
This incident affected: GeorgiaVIEW Online Learning (GeorgiaVIEW Online Learning Environment (QPROD)).