SYSTEMS STATUS
Network Printing Issues Reported
Incident Report for USG Services
Resolved
ITS has confirmed that network printing is functioning normally at this time.

In the event that you experience any further issues with network printing, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Apr 14, 2016 - 10:14 EDT
Investigating
ITS is currently investigating reports of an issue with network printers. Affected users may be experiencing issues printing. Additional information will be posted here when it becomes available.
Posted Apr 14, 2016 - 09:55 EDT
This incident affected: PeachNet Network (USO Athens Office).