SYSTEMS STATUS
Georgia Public Library Service Network Issues Reported
Incident Report for USG Services
Resolved
ITS has confirmed that GPLS is functioning normally at this time.

In the event that you experience any further issues with GPLS, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 2 months ago. Jul 12, 2017 - 10:04 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of an issue with a network outage at GPLS. Affected users may be experiencing no internet connection. Additional information will be posted here when it becomes available.
Posted 2 months ago. Jul 12, 2017 - 09:09 EDT