SYSTEMS STATUS
Blackboard Collaborate Issues Reported
Incident Report for USG Services
Resolved
ITS has confirmed that all Blackboard Collaborate issues have been resolved and the system is functioning normally.
Posted Mar 22, 2016 - 13:52 EDT
Investigating
ITS is currently investigating reports of issues with Blackboard Collaborate. Ultra and Original Web Conferencing sessions will not load. Affected users may be seeing "System Maintenance Notification". Blackboard is working to identify and resolve the issue.
Posted Mar 22, 2016 - 13:49 EDT