SYSTEMS STATUS
GeorgiaFIRST PeopleSoft Financial Service Issues Reported
Incident Report for USG Services
Resolved
Further information regarding this issue can be found at: https://www.usg.edu/gafirst-fin/known_issues
Reference:KI9.2-103_Other under Active Known Issues.
Posted 2 months ago. Feb 12, 2019 - 14:04 EST
Update
Information Technology Services (ITS) continues to investigate this issue.

Additional information will be posted here as it becomes available.
Posted 3 months ago. Jan 23, 2019 - 13:44 EST
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with the GeorgiaFIRST PeopleSoft Financial Service. Affected users may randomly be logged out early with the following error message, “Your PeopleSoft connection has expired". If you get this message, please provide full details including the user, specific activity and approximate time and to open a ticket, email the ITS Helpdesk at: helpdesk@usg.edu Include the URL that you got the error message from, a screen shot of the error message and the browser you were using.

Additional information will be posted here as it becomes available.
Posted 3 months ago. Jan 18, 2019 - 16:36 EST
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financials, GeorgiaFIRST Marketplace).