SYSTEMS STATUS
GeorgiaFIRST Peoplesoft Financials - Unable to log in
Incident Report for USG Services
Resolved
After monitoring the situation for the past 3 hours, Information Technology Services has confirmed the stability of GeorgiaFIRST PeopleSoft Financials. The system should continue operating normally.

In the event that you experience any further issues with GeorgiaFIRST PeopleSoft Financials, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Apr 26, 2017 - 15:09 EDT
Monitoring
Information Technology Services (ITS) has confirmed that users are now able to log into GeorgiaFIRST PeopleSoft Financials. We will continue to monitor the system for any further performance issue throughout the afternoon.
In the event that you experience any further issues with GeorgiaFIRST PeopleSoft Financials, please contact the ITS Helpdesk at helpdesk@usg.edu or by calling (706) 583-2001.
Posted Apr 26, 2017 - 12:28 EDT
Investigating
Information Technology Services has identified a problem with GeorgiaFIRST Peoplesoft Financials and are currently working to resolve the issue. It has been reported that users cannot log in and users that were logged in were kicked out of the application. We are currently working to resolve the issue and will provide updates as they become available. If you have questions, please contact us at helpdesk@usg.edu or (706) 583-2001
Posted Apr 26, 2017 - 11:54 EDT
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financials).