SYSTEMS STATUS
GeorgiaBEST Managed Services - Degree Works Issues Reported
Incident Report for USG Services
Resolved
Verification that the issue is resolved and expected behavior should now be encountered when using Banner Managed Services at South Georgia State College.
Posted Jan 05, 2022 - 10:26 EST
Monitoring
Information Technology Services (ITS) has confirmed restoration of functionality to the Banner Managed Services - DegreeWorks for South Georgia State College.

Connectivity to the database has been restored and no other issues are anticipated at this time.

In the event that you experience any further issues accessing Banner Managed Services - Degree Works, please contact the ITS Helpdesk at: helpdesk@usg.edu or 706-583-2001.
Posted Jan 04, 2022 - 10:40 EST
Investigating
Information Technology Services (ITS) has received reports of users experiencing connection issues.

We are actively monitoring and will provide updates as they are made available.

We are committed to resolving this issue as quickly as possible and we apologize for any inconvenience this may cause. We will provide an update as soon as more information is available.

Components affected:

- South Georgia State College
Posted Jan 04, 2022 - 09:57 EST
This incident affected: GeorgiaBEST Degree Works Managed Services (South Georgia State College).