SYSTEMS STATUS
GIL Courier Service Schedule Interruption
Incident Report for USG Services
Resolved
GIL Express Courier Service has resumed normal delivery and pickup.
Posted 2 months ago. Oct 10, 2017 - 08:17 EDT
Identified
In observation of Columbus Day, GIL Express Courier Service will not make deliveries or pickups on Monday, October 9, 2017.

Normal GIL Express Courier Services are expected to resume on Tuesday, October 10, 2017.
Posted 2 months ago. Oct 06, 2017 - 13:36 EDT
This incident affected: GALILEO - Georgia's Virtual Library (GIL Express).