SYSTEMS STATUS
Network Outage Affecting Multiple DOE Locations in Southeast Georgia
Incident Report for USG Services
Resolved
ITS has confirmed that power has been restored and all DOE locations are functioning normally at this time.

In the event that you experience any further issues with network outages for Ga DOE K-12 please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted May 24, 2017 - 08:24 EDT
Investigating
Information Technology Services (ITS) is reporting multiple K-12network outages in Southeast Georgia. ITS has been is aware and is working on the issue. Additional information will be posted here when it becomes available.
Posted May 23, 2017 - 19:25 EDT
This incident affected: GA DOE K-12 Network.