SYSTEMS STATUS
GeorgiaBEST - College of Coastal Georgia - Cyber Attack
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed functionality of GeorgiaBEST Banner Managed Services at College of Coastal Georgia. The system should continue operating normally.

In the event that you experience any further access issues, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted May 09, 2022 - 11:44 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of a cyber attack at the College of Coastal Georgia that is affecting access to the student information system and degree audit system. Affected users are unable to access Banner and Degree Works. Additional information will be posted here when the issues are confirmed.
Posted May 05, 2022 - 11:11 EDT
This incident affected: GeorgiaBEST Degree Works Managed Services (College of Coastal Georgia) and GeorgiaBEST Banner Managed Services (College of Coastal Georgia).