SYSTEMS STATUS
Plant-Tel/BST Outage Affecting Multiple K12 Sites
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that the network is functioning normally at this time.

In the event that you experience any further issues with network please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 4 months ago. Aug 06, 2018 - 13:34 EDT
Investigating
Information Technology Services (ITS) is currently investigating a Plant-Tel/BST outage affecting multiple K-12 sites in the Savannah area. Users at these locations will experience network outages. Additional information will be posted here as it becomes available.

Sites Affected:
Bryan County
Evans County
Candler County
Treutlen County
Toombs Count
Vidalia City
Posted 4 months ago. Aug 06, 2018 - 09:46 EDT
This incident affected: GA DOE K-12 Network.