SYSTEMS STATUS
Network Outage - South Georgia State College
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that South Georgia State College's network should be functioning normally at this time.

In the event that you experience any further issues, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 2 months ago. Sep 13, 2017 - 08:43 EDT
Identified
Information Technology Services (ITS) has confirmed that issues with South Georgia State College are being caused by power outage. ITS technical staff are working to restore full functionality of this system as quickly as possible. Additional information will be posted here as it becomes available.
Posted 2 months ago. Sep 11, 2017 - 11:41 EDT
This incident affected: PeachNet Network (South Georgia State College).