SYSTEMS STATUS
Network Outage Affecting Multiple DOE Locations
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that network access for Morgan County Schools, Newton County Schools, and Social Circle City Schools is functioning normally at this time.

In the event that you experience any further issues with network access, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 4 months ago. Mar 25, 2019 - 16:29 EDT
Investigating
Information Technology Services (ITS) is reporting multiple K-12 network outages in the Atlanta area. ITS has contacted AT&T to determine the cause, and escalate the issue with their repair center. The following schools are being affected by this outage:

- Morgan County Schools
- Newton County Schools
- Social Circle City Schools

Additional information will be posted here as it becomes available.
Posted 4 months ago. Mar 25, 2019 - 09:27 EDT
This incident affected: GA DOE K-12 Network.