SYSTEMS STATUS
USO Telephone Issues At Atlanta Office
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that issues with the AT&T telephone circuit have been resolved.

In the event that you experience any further issues with call quality in the Atlanta USO office, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 24 days ago. Nov 21, 2018 - 08:33 EST
Investigating
Information Technology Services (ITS) is currently investigating reports of an issue with the Atlanta USO office. Atlanta users can receive calls, however, affected users may be experiencing poor phone call quality. Additional information will be posted here when it becomes available.
Posted 29 days ago. Nov 16, 2018 - 16:54 EST
This incident affected: Internal USO Services (USO Telephone System).