SYSTEMS STATUS
Office 365 Email Issues Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that Office 365 Email is functioning normally at this time.

In the event that you experience any further issues with Office 365 Email, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Oct 17, 2018 - 16:14 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of an issue with Office 365 Email. Affected users may be experiencing delayed receipt of email. Additional information will be posted here when it becomes available.
Posted Oct 17, 2018 - 09:03 EDT
This incident affected: Internal USO Services (USO Email and Calendar).