SYSTEMS STATUS
GALILEO EBSCO Discovery Service Search Errors
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that the EBSCO Discovery Service is functioning normally at this time.

In the event that you experience any further issues with EBSCO, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Dec 09, 2017 - 20:14 EST
Investigating
Since approximately 1:15 p.m., December 9, 2017, EBSCO has been experiencing intermittent access issues impacting EBSCO Discovery Service. EBSCO is aware of the issue and their staff are working to identify the cause of the issue and resolve it as soon as possible. There is currently no estimated time of resolution.

Additional information will be posted here when the issues are confirmed
Posted Dec 09, 2017 - 19:12 EST
This incident affected: GALILEO - Georgia's Virtual Library (GALILEO).