SYSTEMS STATUS
Certificate Issues Reported Affecting www.usg.edu Websites
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that the issues with certificates affecting the www.usg.edu website and custom web applications appear to be resolved. The system should continue operating normally at this time.

If you are still experiencing issues with the www.usg.edu website, subsites, and/or custom web applications, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Jun 22, 2022 - 13:18 EDT
Monitoring
Information Technology Services (ITS) received reports of certificate errors with various subsites of the www.usg.edu website and custom web applications. ITS has confirmed that these issues appear to be resolved. We will continue to monitor this system for stability.

If you are still experiencing issues with the www.usg.edu website, subsites, and/or custom web applications, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Jun 22, 2022 - 11:36 EDT
This incident affected: Web Services (www.usg.edu).