SYSTEMS STATUS
GeorgiaBEST Nelnet Issues Reported - Albany State University
Incident Report for USG Services
Resolved
Albany State University Nelnet Payment Plan issues have been resolved.

If the institution is still experiencing issues with Nelnet Payment Plans, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted May 05, 2022 - 17:40 EDT
Monitoring
Information Technology Services (ITS) is currently monitoring student access at Albany State University for Nelnet Payment Plans via Banner Self-Service. Additional information will be posted here when the issues are resolved.
Posted May 05, 2022 - 17:10 EDT
This incident affected: GeorgiaBEST Banner Managed Services (Albany State University).