SYSTEMS STATUS
GeorgiaFIRST PeopleSoft Financial Service Issues Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) confirmed that the PeopleSoft Financials production database (FPROD) is functioning normally at this time.

In the event users experience any further issues with GeorgiaFIRST PeopleSoft Financial Service, please contact the ITS Helpdesk at: helpdesk@usg.edu.
Posted Feb 25, 2021 - 14:33 EST
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with the GeorgiaFIRST PeopleSoft Financial Service. Affected users may be experiencing an Oracle error when trying to access PeopleSoft. Additional information will be posted here as it becomes available.
Posted Feb 25, 2021 - 12:50 EST
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financials).