SYSTEMS STATUS
Georgia Public Library Service Network Issues Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that Georgia Public Library Service is functioning normally at this time.

In the event that you experience any further issues with network access please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 9 days ago. Sep 13, 2017 - 08:50 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of an issue with a network outage at GPLS. Affected users may be experiencing no internet connection. Additional information will be posted here when it becomes available.
Posted 11 days ago. Sep 11, 2017 - 17:57 EDT
This incident affected: PeachNet Network (Georgia Public Library Service).