SYSTEMS STATUS
DUO Two-Factor Authentication Issues Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that DUO Two-Factor Authentication is functioning normally at this time.

In the event that you experience any further issues with DUO Two-Factor Authentication, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 4 days ago. Jan 11, 2019 - 09:33 EST
Investigating
Information Technology Services (ITS) is currently investigating reports of an issue with DUO Two-Factor Authentication. Affected users may be unable to approve Two-Factor Authentication prompts. Additional information will be posted here when it becomes available.
Posted 5 days ago. Jan 10, 2019 - 16:23 EST
This incident affected: Internal USO Services (USO SSO).