SYSTEMS STATUS
GeorgiaFIRST Marketplace Issue Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has worked with Jaggaer to resolve the issue with Lenovo punchout. Lenovo punchout is now up and ready to use. You will however, notice that the site has been updated and improved, which has caused changes to the appearance of the site. The functionality of the site remains the same.

If you have any questions or require any further assistance, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 6 months ago. Mar 22, 2017 - 17:09 EDT
Update
Information Technology Services (ITS) continues to be in contact with Jaggaer (formerly SciQuest) and Lenovo who are actively working to resolve this issue. Until the issue is resolved, please create a Special Request requisition for any Lenovo orders that need to be processed. Additional information will be posted here once it becomes available.
Posted 6 months ago. Mar 22, 2017 - 08:14 EDT
Update
Information Technology Services (ITS) continues to be in contact with Jaggaer (formerly SciQuest) and Lenovo who are actively working to resolve this issue. Additional information will be posted here once it becomes available.
Posted 6 months ago. Mar 21, 2017 - 11:21 EDT
Investigating
Information Technology Services (ITS) has confirmed that Lenovo Punchout is not available.
ITS is in contact with Jaggaer (formerly SciQuest) and Lenovo and they are actively working to resolve this issue. Additional information will be posted here once it becomes available.
Posted 6 months ago. Mar 20, 2017 - 15:39 EDT
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST Marketplace).