SYSTEMS STATUS
Network Outage - Georgia Archives Record Center
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that the Georgia Archives Record Center is functioning normally at this time.

In the event that you experience any further issues with the Georgia Archives Record Center, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 2 months ago. Sep 11, 2018 - 08:11 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of an issue with Georgia Archives Record Center. Affected users may be experiencing loss of internet connectivity. Additional information will be posted here when it becomes available.
Posted 2 months ago. Sep 10, 2018 - 13:56 EDT
This incident affected: PeachNet Network (Georgia Archives).