SYSTEMS STATUS
Blackboard Collaborate Issues Reported
Incident Report for USG Services
Resolved
ITS has confirmed that all Blackboard Collaborate issues have been resolved and the system is functioning normally.
Posted Jun 24, 2016 - 18:42 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with Blackboard Collaborate. Affected users may be experiencing issues with Collaborate Ultra and Original Web Conferencing sessions not loading. Additional information will be posted here when the issues are confirmed.
Posted Jun 24, 2016 - 15:55 EDT