SYSTEMS STATUS
GoVIEW Telephone Issues Reported
Incident Report for USG Services
Resolved
ITS has confirmed that GoVIEW Telephones are functioning normally at this time.

In the event that you experience any further issues with GoVIEW Telephones, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Jul 19, 2017 - 08:27 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of an telephone issue with GoVIEW. For eMajor and eCampus students, the phone support lines are currently unavailable. If you need assistance, please contact ecore@westga.edu or emajor@westga.edu. Additional information will be posted here when it becomes available.
Posted Jul 18, 2017 - 10:38 EDT
This incident affected: Georgia ONmyLINE.