SYSTEMS STATUS
GeorgiaFIRST Marketplace Issues Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that GeorgiaFIRST Marketplace is functioning normally at this time.

In the event that you experience any further issues with GeorgiaFIRST Marketplace, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 18 days ago. Feb 05, 2018 - 17:14 EST
Identified
Information Technology Services (ITS) has confirmed that the GeorgiaFIRST Marketplace Production environment is currently down. There is a performance issue in the GeorgiaFIRST Marketplace. Please be aware that JAGGAER is actively working to remediate this issue.

Additional information will be posted here as it becomes available.
Posted 18 days ago. Feb 05, 2018 - 16:38 EST
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST Marketplace).