SYSTEMS STATUS
GeorgiaBEST Managed Services Issue Reported - Albany State University
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of GeorgiaBEST Managed Services at Albany State University. The system should continue operating normally.

In the event that you experience any further issues with access to GeorgiaBEST Managed Services, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted May 16, 2022 - 15:09 EDT
Monitoring
Information Technology Services (ITS) has restored functionality of GeorgiaBEST Managed Services at Albany State University. We will continue to monitor this system for stability. If you are still experiencing connectivity issues, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted May 14, 2022 - 15:02 EDT
Investigating
Information technology (ITS) is currently investigating reports of issues with GeorgiaBEST Managed Services. Affected users may be experiencing errors when logging into Banner. Additional information will be posted here when the issues are confirmed.
Posted May 14, 2022 - 13:05 EDT
This incident affected: GeorgiaBEST Banner Managed Services (Albany State University).