SYSTEMS STATUS
Archives Records Center Network Outage
Incident Report for USG Services
Resolved
ITS has confirmed that the Archives Records Center is back online. If you experience any further issues, please contact the ITS Helpdesk at helpdesk@usg.edu or (706) 583-2001
Posted 5 months ago. Mar 13, 2017 - 12:30 EDT
Identified
Information Technology Services (ITS) has confirmed a power outage affecting network access for the Archives Records Center. Additional information will be posted here when it becomes available.
Posted 5 months ago. Mar 13, 2017 - 11:56 EDT
This incident affected: PeachNet Network (Georgia Archives).