SYSTEMS STATUS
OneUSG Connect Careers Portal Access Issue
Incident Report for USG Services
Resolved
The OneUSG Connect Careers Portal is now available for regular use. If you experience issues, please clear your cookies and cache and refresh your browser.

In the event that you experience any further issues, please contact OneUSG Connect Support by email at: oneusgsupport@usg.edu.
Posted Mar 01, 2021 - 14:37 EST
Investigating
The OneUSG Connect Careers Portal is unavailable. Support is aware of the issue and working diligently to fix the issue.

We are committed to resolving this issue as quickly as possible and we apologize for any inconvenience this may cause. We will provide an update as soon as more information is available.

If you have questions or concerns, please contact OneUSG Connect Support by email at: oneusgsupport@usg.edu
Posted Mar 01, 2021 - 10:40 EST
This incident affected: OneUSG Connect (OneUSG Connect- Careers Applicant Access).