SYSTEMS STATUS
USO Shared Services Center Telephone System Issues Reported
Incident Report for USG Services
Resolved
The University System of Georgia Shared Services Center (SSC) has confirmed that the intermittent phone technical issues have been resolved.

If you are unable to contact us via phone, please send an email to oneusgsupport@usg.edu with your name and telephone contact information. A representative from our Customer Support Team will contact you.
Posted Oct 22, 2020 - 09:38 EDT
Investigating
The University System of Georgia Shared Services Center (SSC) is experiencing intermittent phone technical issues.

If you are unable to contact us via phone, please send an email to oneusgsupport@usg.edu with your name and telephone contact information. A representative from our Customer Support Team will contact you.

Thank you for your patience as we work through this temporary situation.

Additional information will be posted here as it becomes available.
Posted Oct 21, 2020 - 16:08 EDT
This incident affected: PeachNet Network (USO Shared Services Center).