SYSTEMS STATUS
GIL Courier Service Schedule Interruption
Incident Report for USG Services
Resolved
This incident has been resolved.
Posted Dec 09, 2016 - 17:13 EST
Identified
Due to vehicle issues, GIL Express Courier Service will not make deliveries or pickups to the following USG libraries today:

- College of Coastal Georgia

Normal GIL Express Courier Services are expected to resume Monday.
Posted Dec 09, 2016 - 11:54 EST
This incident affected: GALILEO - Georgia's Virtual Library (GIL Express).