SYSTEMS STATUS
Network maintenance - Bainbridge State College
Incident Report for USG Services
Resolved
ITS has confirmed that network access at Bainbridge State College is functioning normally at this time.

In the event that you experience any further issues with network access, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Oct 28, 2016 - 18:25 EDT
Identified
ITS has been notified that Bainbridge State College is conducting generator maintenance. Users may experience internet connectivity issues during this time.
Posted Oct 28, 2016 - 14:16 EDT