SYSTEMS STATUS
GeorgiaBEST Managed Services Issue Reported
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of Banner Self Service applications. The system should continue operating normally.

In the event that you experience any further issues with Banner Self Service applications, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Oct 14, 2021 - 17:05 EDT
Monitoring
Information Technology Services (ITS) has detected possible problems with Banner environments that may affect logging into Self Service applications. We are monitoring this situation. Updates will be posted here as they become available.

Sites Affected:

- College of Coastal Georgia
- Clayton State University
- Valdosta State University
- University of West Georgia
Posted Oct 14, 2021 - 11:15 EDT
This incident affected: GeorgiaBEST Banner Managed Services (Clayton State University, College of Coastal Georgia, University of West Georgia, Valdosta State University).