SYSTEMS STATUS
GeorgiaBEST Managed Services Albany State University Issues Reported
Incident Report for USG Services
Resolved
ITS has confirmed that GeorgiaBEST Managed Services is functioning normally at this time.

In the event that you experience any further issues with GeorgiaBEST Managed Services, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 9 months ago. Mar 11, 2017 - 21:20 EST
Investigating
Information Technology Services (ITS) is currently investigating Albany State University reports of issues with GeorgiaBEST Managed Services. Affected users may be experiencing application access issues. Additional information will be posted here when the issues are confirmed.
Posted 9 months ago. Mar 11, 2017 - 20:16 EST
This incident affected: GeorgiaBEST Banner Managed Services (Albany State University).