SYSTEMS STATUS
GeorgiaBEST Banner & Degree Works Managed Services Application Not Loading
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that GeorgiaBEST Banner Managed Services and Degree Works Managed Services are functioning normally at this time.

In the event that you experience any further issues with GeorgiaBEST Banner Managed Services or Degree Works Managed Services please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 4 months ago. Mar 07, 2018 - 12:54 EST
Investigating
Information Technology Services (ITS) has identified an issue with accessing the Banner Managed Services and Degree Works Managed Services. We are currently investigating the issue. 

GeorgiaBEST Banner Managed Services
Abraham Baldwin Agricultural College
Albany State University
Armstrong State University
Atlanta Metropolitan State College
Bainbridge State College
Dalton State College
Fort Valley State University
Georgia Gwinnett College
Georgia Southwestern State University
Savannah State University
South Georgia State College

=============================================

GeorgiaBEST Degree Works Managed Services Institutions:
Abraham Baldwin Agricultural College
Armstrong State University
Atlanta Metropolitan State College
Bainbridge State College
College of Coastal Georgia
Columbus State University
Dalton State College
Fort Valley State University
Georgia Gwinnett College
Georgia Southwestern State University
Savannah State University
South Georgia State College

ITS technical staff are working to resolve the issue as soon as possible. 

Additional information will be posted here as  it becomes available
Posted 4 months ago. Mar 07, 2018 - 09:51 EST
This incident affected: GeorgiaBEST Degree Works Managed Services (Abraham Baldwin Agricultural College, Armstrong State University, Atlanta Metropolitan State College, Bainbridge State College, College of Coastal Georgia, Columbus State University, Dalton State College, Fort Valley State University, Georgia Gwinnett College, Georgia Southwestern State University, Savannah State University, South Georgia State College) and GeorgiaBEST Banner Managed Services (Abraham Baldwin Agricultural College, Albany State University, Atlanta Metropolitan State College, Bainbridge State College, Dalton State College, Fort Valley State University, Georgia Gwinnett College, Georgia Southwestern State University, Savannah State University, South Georgia State College).