SYSTEMS STATUS
GeorgiaFIRST Marketplace Issue Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that access to the GeorgiaFIRST Marketplace is functioning normally at this time. In the event that you experience any further issues with accessing GeorgiaFIRST Marketplace please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Oct 22, 2020 - 09:08 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with GeorgiaFIRST Marketplace. Affected users will not be able to access the GeorgiaFIRST Marketplace, and may receive errors such as "An error occurred while connecting to supplier's website". Additional information will be posted here when the issues are resolved.
Posted Oct 21, 2020 - 10:21 EDT
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST Marketplace).