SYSTEMS STATUS
GIL Courier Service Schedule: Monday, November 12, 2018
Incident Report for USG Services
Resolved
This incident has been resolved. Pick up and deliveries are back to normal.
Posted 4 days ago. Nov 12, 2018 - 17:05 EST
Identified
In observance of Veteran's Day on Sunday, November 11, 2018 STAT Courier will not be making deliveries or pickups on Monday, November 12, 2018.
Posted 8 days ago. Nov 08, 2018 - 15:15 EST
This incident affected: GALILEO - Georgia's Virtual Library (GIL Express).