SYSTEMS STATUS
Network Outage - Savannah State University
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that Network access is functioning normally at this time.

In the event that you experience any further issues with access to the Network, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Mar 12, 2018 - 08:08 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of a network outage at Savannah State University. Affected users may not be able to access the internet. Additional information will be posted here when it becomes available.
Posted Mar 12, 2018 - 01:39 EDT
This incident affected: PeachNet Network (Savannah State University).