SYSTEMS STATUS
GeorgiaFIRST PeopleSoft Financial Service Issues Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that the GeorgiaFIRST PeopleSoft Financial Service is functioning normally at this time.

In the event that you experience any further issues with logging into FPROD, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Jan 19, 2018 - 13:13 EST
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with the GeorgiaFIRST PeopleSoft Financial Service. Affected users may be experiencing difficulties logging into FPROD. Additional information will be posted here as it becomes available.
Posted Jan 19, 2018 - 12:22 EST
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financials).